Senin, 13 Juni 2011

Tugas Jarkom3 Praktek

Step 1: Connecting the network
  1. Utilize the first FastEthernet interface on the ISR router to connect to the last FastEthernet interface on the Floor 1 switch.
  2. Connect GigabitEthernet 1/1 on the Floor 1 switch to GigabitEthernet 1/1 on the Floor 2 switch.
  3. Connect GigabitEthernet 1/2 on the Floor 2 switch to GigabitEthernet 1/1 on the Floor 3 switch.


Step 2: Configure basic switch and router configurations
Utilize the following table to configure the ISR router, Floor 1, Floor 2, and Floor 3 switches.


1. ISR router
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname ISR_Rtr
ISR_Rtr(config)#enable pass cisco123
ISR_Rtr(config)#line vty 0 4
ISR_Rtr(config-line)#pass class
ISR_Rtr(config-line)#login
ISR_Rtr(config-line)#line console 0
ISR_Rtr(config-line)#pass class
ISR_Rtr(config-line)#login
ISR_Rtr(config-line)#^Z
%SYS-5-CONFIG_I: Configured from console by console
ISR_Rtr#wr mem
Building configuration...
[OK]
2. Floor1 switch
Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname Floor1_Sw
Floor1_Sw(config)#enable pass cisco123
Floor1_Sw(config)#line vty 0 4
Floor1_Sw(config-line)#pass class
Floor1_Sw(config-line)#login
Floor1_Sw(config-line)#line console 0
Floor1_Sw(config-line)#pass class
Floor1_Sw(config-line)#login
Floor1_Sw(config-line)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Floor1_Sw#wr mem
Building configuration...
[OK]
3. Floor2 switch
Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname Floor2_Sw
Floor2_Sw(config)#enable pass cisco123
Floor2_Sw(config)#line vty 0 4
Floor2_Sw(config-line)#pass class
Floor2_Sw(config-line)#login
Floor2_Sw(config-line)#line console 0
Floor2_Sw(config-line)#pass class
Floor2_Sw(config-line)#login
Floor2_Sw(config-line)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Floor2_Sw#wr mem
Building configuration...
[OK]

4. Floor3 switch
Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname Floor3_Sw
Floor3_Sw(config)#enable pass cisco123
Floor3_Sw(config)#line vty 0 4
Floor3_Sw(config-line)#pass class
Floor3_Sw(config-line)#login
Floor3_Sw(config-line)#line console 0
Floor3_Sw(config-line)#pass class
Floor3_Sw(config-line)#login
Floor3_Sw(config-line)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Floor3_Sw#wr mem
Building configuration...
[OK]

Step 3: Configure the interfaces connecting the router and switches
a. Set the interfaces connecting the Floor 1, Floor 2, and Floor 3 switches as trunk ports.
b. Set the interface on the Floor 1 switch connecting to the ISR router as a trunk port. 

FLOOR1
Floor1_Sw#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Floor1_Sw(config)#int fa0/24
Floor1_Sw(config-if)#switchport mode trunk
Floor1_Sw(config-if)#int gig1/1
Floor1_Sw(config-if)#switchport mode trunk
Floor1_Sw(config-if)#no shut
Floor1_Sw(config-if)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Floor1_Sw#wr mem
Building configuration...
[OK]

FLOOR2
Floor2_Sw#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Floor2_Sw(config)#int gig1/1
Floor2_Sw(config-if)#switchport mode trunk
Floor2_Sw(config-if)#int gig1/2
Floor2_Sw(config-if)#switchport mode trunk
Floor2_Sw(config-if)#no shut
Floor2_Sw(config-if)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Floor2_Sw#wr mem
Building configuration...
[OK]
           FLOOR3
           Floor3_Sw#conf t
           Enter configuration commands, one per line.  End with CNTL/Z.
           Floor3_Sw(config)#int gig1/1
           Floor3_Sw(config-if)#switchport mode trunk
           Floor3_Sw(config-if)#^Z
           %SYS-5-CONFIG_I: Configured from console by console
           Floor3_Sw#wr mem
           Building configuration...
           [OK]

         c. Enable the interface on the ISR router connecting to the Floor 1 switch.
         d. Create and configure three sub-interfaces on the ISR routers FastEthernet 0/0
             interface.Use the following table.
              1.  Set the encapsulation for each sub-interface.
              2.  Set the IP address for each sub-interface.

ISR_Rtr#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ISR_Rtr(config)#int fa0/0
ISR_Rtr(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
ISR_Rtr(config-if)#int fa0/0.20

%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up
ISR_Rtr(config-subif)#encapsulation dot1q 20
ISR_Rtr(config-subif)#ip add 192.168.20.1 255.255.255.0
ISR_Rtr(config-subif)#no shut
ISR_Rtr(config-subif)#exit
ISR_Rtr(config)#int fa0/0.25

%LINK-5-CHANGED: Interface FastEthernet0/0.25, changed state to up
ISR_Rtr(config-subif)#encapsulation dot1q 25
ISR_Rtr(config-subif)#ip add 192.168.25.1 255.255.255.0
ISR_Rtr(config-subif)#no shut
ISR_Rtr(config-subif)#exit
ISR_Rtr(config)#int fa0/0.30

%LINK-5-CHANGED: Interface FastEthernet0/0.30, changed state to up
ISR_Rtr(config-subif)#encapsulation dot1q 30
ISR_Rtr(config-subif)#ip add 192.168.30.1 255.255.255.0
ISR_Rtr(config-subif)#no shut
ISR_Rtr(config-subif)#exit
ISR_Rtr(config)#^Z
%SYS-5-CONFIG_I: Configured from console by console
ISR_Rtr#wr mem
Building configuration...
[OK]
       
        
Step 4: Configure a VTP Domain
Utilize the following table to configure the Floor 1, Floor 2, and Floor 3 switches.
a.Configure the Floor 2 and Floor 3 switches as VTP clients.
1.Set the VTP domain.
2.Set the VTP mode.
3.Set the VTP password. 

 Floor2 switch
Floor2_Sw#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Floor2_Sw(config)#vtp domain
% Incomplete command.
Floor2_Sw(config)#vtp domain SiteX
Changing VTP domain name from NULL to SiteX
Floor2_Sw(config)#vtp mode client
Setting device to VTP CLIENT mode.
Floor2_Sw(config)#vtp pass ciscoVTP
Setting device VLAN database password to ciscoVTP
Floor2_Sw(config)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Floor2_Sw#wr mem
Building configuration...
[OK]
 
 Floor3 switch
Floor3_Sw#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Floor3_Sw(config)#vtp domain SiteX
Domain name already set to SiteX.
Floor3_Sw(config)#vtp mode client
Setting device to VTP CLIENT mode.
Floor3_Sw(config)#vtp pass ciscoVTP
Setting device VLAN database password to ciscoVTP
Floor3_Sw(config)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Floor3_Sw#wr mem
Building configuration...
[OK]

b.Configure the Floor 1 switch as a VTP server.
1.Set the VTP domain.
2.Set the VTP mode.
3.Set the VTP password.
 
 Floor1 switch
Floor1_Sw#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Floor1_Sw(config)#vtp domain SiteX
Domain name already set to SiteX.
Floor1_Sw(config)#vtp mode server
Device mode already VTP SERVER.
Floor1_Sw(config)#vtp pass ciscoVTP
Setting device VLAN database password to ciscoVTP
Floor1_Sw(config)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Floor1_Sw#wr mem
Building configuration...
[OK]

Step 5: Configure VLANs
Utilize the following table to configure the VLANs from the VTP server.

Floor1_Sw#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Floor1_Sw(config)#vlan 20
Floor1_Sw(config-vlan)#name Admin
Floor1_Sw(config-vlan)#vlan 25
Floor1_Sw(config-vlan)#name Management
Floor1_Sw(config-vlan)#vlan 30
Floor1_Sw(config-vlan)#name Finance
Floor1_Sw(config-vlan)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Floor1_Sw#wr mem
Building configuration...
[OK]

Step 6: Add switch ports to the appropriate VLAN
a. Configure the Floor 1 switch so that FastEthernet 0/1 is on VLAN 20. 

Floor1_Sw#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Floor1_Sw(config)#int fa0/1
Floor1_Sw(config-if)#switchport mode access
Floor1_Sw(config-if)#switchport access vlan 20
Floor1_Sw(config-if)#no shut
Floor1_Sw(config-if)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Floor1_Sw#wr mem
Building configuration...
[OK]

b. Configure the Floor 2 switch so that FastEthernet 0/1 is on VLAN 25. 

Floor2_Sw#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Floor2_Sw(config)#int fa0/1
Floor2_Sw(config-if)#switchport mode access
Floor2_Sw(config-if)#switchport access vlan 25
Floor2_Sw(config-if)#no shut
Floor2_Sw(config-if)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Floor2_Sw#wr mem
Building configuration...
[OK]

c. Configure the Floor 3 switch so that FastEthernet 0/1 is on VLAN 30.
Floor3_Sw#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Floor3_Sw(config)#int fa0/1
Floor3_Sw(config-if)#switchport mode access
Floor3_Sw(config-if)#switchport access vlan 30
Floor3_Sw(config-if)#no shut
Floor3_Sw(config-if)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Floor3_Sw#wr mem
Building configuration...
[OK]

Step 7: Connect and configure client workstations
a. Connect PC0 to the Floor 1 switch via FastEthernet 0/1.
b. Connect PC1 to the Floor 2 switch via FastEthernet 0/1.
c. Connect PC2 to the Floor 3 switch via FastEthernet 0/1.

 

Step 8: Verify connectivity




REFLECTION:

a. what is the advantage of using VTP to manage VLANs
b. what are some advantages and disadvantages of implementating VLANs
c. what required for host on different VLANs to communicate with each other?

a.we can create, modify, and delete VLAN parameters
   VLAN configuration to the entire domain by using a single switch
   which switches that use the server mode

b.advantages:
1. Reduce network traffic (traffic load), because the VLAN segmentation done
  LAN into several smaller LANs.
2. Optimization of network more flexible, because the grouping is not based on user
  physical location, but can be done based on the similarity field / job / division / department.
3. The security level is guaranteed, because it separates the users who work using data
  sensitive at a logically separate VLAN.
4. Save costs, because the distribution layer network into several groups of broadcast domains
  smaller, thus reducing the amount of purchases that much more expensive routers.
5. Ease of network management, by dividing the number of administrators for each subnet.

  loss:
1.loss defines VLANs based on port is a manager network must merekonfigurasi membership
VLAN when one user moves from one port to another p o r t
2.loss of VLANs based on MAC addresses are all user must be configured to be
VLAN members. After manual configuration , the search is an automatic user possible, depending on the product switches are used where a specific vendor.

c.required by the host to communicate on a different vlan is a router


a. apa keuntungan dari menggunakan VTP untuk mengelola VLAN
b. sebutkan beberapa keuntungan dan kerugian dari implementasi VLAN
c. apa yang diperlukan untuk host pada VLAN yang berbeda untuk berkomunikasi satu sama lain?

a.kita dapat membuat, mengubah, menghapus VLAN dan parameter
  konfigurasi VLAN ke seluruh domain dengan menggunakan satu switch
  yaitu switch yang menggunakan mode server

b.keuntungan:
1.Mengurangi traffik jaringan (load traffic), karena dalam VLAN dilakukan segmentasi
 LAN menjadi beberapa LAN yang lebih kecil.
2.Optimasi jaringan yang lebih flexible, karena pengelompokan user tidak berdasarkan
 lokasi fisik, tapi bisa dilakukan berdasarkan kesamaan bidang/pekerjaan/divisi/departemen.
3.Tingkat keamaan lebih terjamin, karena memisahkan user-user yang bekerja menggunakan data-data
 yang sensitif pada satu VLAN yang terpisah secara logika.
4.Menghemat biaya, karena pembagian jaringan layer ke dalam beberapa kelompok broadcast domain
 yang lebih kecil, sehingga mengurangi jumlah pembelian router yang jauh lebih mahal.
5.Memudahkan manajemen jaringan, dengan membagi beberapa administrator untuk tiap subnet.

   kerugian:
1.kerugian mendefinisikan VLAN berdasarkan port adalah manajerjaringan harus merekonfigurasi keanggotaan
VLAN ketika salah satu user berpindah dari satu port ke p o r t lainnya
2.kerugian dari VLAN yang berdasarkan alamat MAC adalah semua user harus dikonfigurasi untuk menjadi
anggota VLAN. Setelah konfigurasi manual tersebut, pencari an otomatis user sangat
dimungkinkan, tergantung pada produk switch vendor mana yang digunakan tertentu.
c.yang dibutuhkan oleh host untuk berkomunikasi pada vlan yang berbeda adalah router


0 komentar:

Posting Komentar

 
Design by Free WordPress Themes | Bloggerized by Lasantha - Premium Blogger Themes | Blogger Templates